HWZ Forums

Login Register FAQ Mark Forums Read

Long Cranking Time (Driving Swift 1.2)

Share This Page
HardwareZone.com on Facebook
Reply
 
LinkBack Thread Tools
Old 08-08-2012, 07:56 PM   #1
Supremacy Member
 
Join Date: Mar 2011
Posts: 6,025
Long Cranking Time (Driving Swift 1.2)

hi,

I have changed new battery and spark plugs liao. but i still experience long cranking time.

anyway to solve the problem.

Usually car starts by the 2nd or 3rd spark. mine is 3rd to 4th spark then start one.
__________________
running on no logic processor
NoLogicLah is offline   Reply With Quote
Old 08-08-2012, 08:53 PM   #2
Master Member
 
Join Date: Jan 2000
Posts: 4,133
The soleniod next to the alternator is acting up.

Ask a workshop to check it.
__________________
[SIZE=1][/SIZE]
bolts is offline   Reply With Quote
Old 08-08-2012, 08:59 PM   #3
Supremacy Member
 
Join Date: Mar 2011
Posts: 6,025
The soleniod next to the alternator is acting up.

Ask a workshop to check it.
alright. need to spend $$ again!
__________________
running on no logic processor
NoLogicLah is offline   Reply With Quote
Old 08-08-2012, 09:44 PM   #4
High Supremacy Member
 
kebinu's Avatar
 
Join Date: Nov 2001
Posts: 31,461
your mech advises you to change the above and it doesn't help? change the mech too! (if he doesnt know how to fix la)
__________________
kevinchia.sg
kebinu is offline   Reply With Quote
Old 08-08-2012, 09:48 PM   #5
Master Member
 
Join Date: Jan 2000
Posts: 4,133
A good workshop will be able to troubleshoot the problem properly and not recommend useless solution.

WS must check the soleniod is getting full 12.6V of battery power to make sure it's not battery or cabling problem. Next thing is the soleniod must engage properly. After that, they have check that the starter motor can run and turn the flywheel that cranks your engine.

If it is confirmed to be the soleniod or starter motor assembly, they will likely replace the whole thing - soleniod and starter motor assembly.

Other thing that can cause slow cranking if it is not battery, soleniod and starter assembly; could be worn timing belt/chain - missing a tooth. Check that too.

and yes, car is a vampire on your pocket.
__________________
[SIZE=1][/SIZE]
bolts is offline   Reply With Quote
Old 08-08-2012, 11:43 PM   #6
Supremacy Member
 
Join Date: Mar 2011
Posts: 6,025
no actually i go by my self diagnose. I feel what is wrong then I go change one by one to rectify the problem. so technically i self pwn. :\

will go a WS to ask for more advise
__________________
running on no logic processor
NoLogicLah is offline   Reply With Quote
Old 09-08-2012, 11:31 AM   #7
Arch-Supremacy Member
 
HKS_Hippo's Avatar
 
Join Date: May 2009
Posts: 24,979
Maybe fuel pump/fuel filter
__________________
Proudly supporting Liverpool since 2013/2014 season
HKS_Hippo is offline   Reply With Quote
Old 09-08-2012, 12:01 PM   #8
Senior Member
 
britneyspears's Avatar
 
Join Date: Nov 2011
Posts: 1,555
starter motor ... check that the pinion is functioning properly ... once u crank the pinion will engage out to turn the flywheel..
__________________
HIT ME BABY ONE MORE TIME!!!!!!!
britneyspears is offline   Reply With Quote
Old 09-08-2012, 05:08 PM   #9
Supremacy Member
 
Join Date: Nov 2011
Posts: 6,301
What is 2nd or 3rd spark???
escksu is offline   Reply With Quote
Old 10-08-2012, 10:08 AM   #10
Member
 
Bernielee's Avatar
 
Join Date: Jun 2010
Posts: 137
maybe plug cable you might wanna take a look?
Bernielee is offline   Reply With Quote
Old 10-08-2012, 10:13 AM   #11
Supremacy Member
 
Join Date: Mar 2011
Posts: 6,025
What is 2nd or 3rd spark???
when you crank right. the tsssk sound is considered as one spark lor. At least thats what i think is going on.

I will drop by a WS on monday to check it up. Though not a really serious major issue, but feels buay song. hahaha
__________________
running on no logic processor
NoLogicLah is offline   Reply With Quote
Old 10-08-2012, 10:26 PM   #12
Senior Member
 
emitchan's Avatar
 
Join Date: Oct 2007
Posts: 862
when you crank right. the tsssk sound is considered as one spark lor. At least thats what i think is going on.

I will drop by a WS on monday to check it up. Though not a really serious major issue, but feels buay song. hahaha
dude u feeling rich? they will tell u change battery, change spark plug change this change that...
emitchan is offline   Reply With Quote
Old 11-08-2012, 09:46 PM   #13
Supremacy Member
 
Kijana's Avatar
 
Join Date: Mar 2005
Posts: 6,284
hi,

I have changed new battery and spark plugs liao. but i still experience long cranking time.

anyway to solve the problem.

Usually car starts by the 2nd or 3rd spark. mine is 3rd to 4th spark then start one.
Check your fuel lines. It might be a bad fuel pump/ clogged fuel rail and injectors. Or simply just because of a dirty fuel filter.

Speaking from experience.
__________________
“An ounce of loyalty is worth a pound of cleverness.”
-Elbert Hubbard
Kijana is offline   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On