HWZ Forums

Login Register FAQ Mark Forums Read

Corbell Product Warranty Policy

Like Tree22Likes
Reply
 
LinkBack Thread Tools
Old 04-12-2017, 12:35 PM   #1066
Arch-Supremacy Member
 
5star_pundit's Avatar
 
Join Date: Aug 2015
Posts: 12,421
Try this link:
https://register.msi.com/home/login?...a_2017_aug_nlw
It should work.
tks, i forgot i already registered in October using another e-mail account.

5star_pundit is offline   Reply With Quote
Old 04-12-2017, 03:11 PM   #1067
Senior Member
 
Join Date: Dec 2011
Posts: 2,211
Hi,

I have a pair of team elite rams TED32048M1333HC9 with the CT stickers and I'm unable to boot with one of the sticks. Can I check if warranty is still under Corbell? Thank you.

alienaire is offline   Reply With Quote
Old 04-12-2017, 04:06 PM   #1068
Featured Distributor for Hardware Clinic, Storage Clinic
 
clon22's Avatar
 
Join Date: Mar 2004
Posts: 8,484
Hi,

I have a pair of team elite rams TED32048M1333HC9 with the CT stickers and I'm unable to boot with one of the sticks. Can I check if warranty is still under Corbell? Thank you.

Hi there,

Can you can send it in and let us check?
Thanks.
__________________

-Local MSI product arrival/price updates: Kabylake/Ryzen
-MSI TwinFrozr Club! Come join our very own SG club!
=My Cooling=
TRU12E Cu LE / Vapo LS Singlestage /
SF3D Inflection Pt CPU pot + Ryba slim GPU pot ver.2
clon22 is online now   Reply With Quote
Old 04-12-2017, 07:26 PM   #1069
Senior Member
 
Join Date: Dec 2011
Posts: 2,211
Hi there,

Can you can send it in and let us check?
Thanks.
Will do, thanks!
alienaire is offline   Reply With Quote
Old 09-12-2017, 09:30 PM   #1070
Senior Member
 
Join Date: Nov 2007
Posts: 956
I just bought 2 units of Xigmatex Tauro G 650 recently....

The PSU emits a humming sound, seems to be from the fan. It's like full blast even when idle / just turn on. Both units are like that, so I'm wondering if this is normal?

If it's not, do I have to bring all the cables for replacement? Or just the PSU will do?
harharhar is offline   Reply With Quote
Old Yesterday, 10:47 AM   #1071
Featured Distributor for Hardware Clinic, Storage Clinic
 
clon22's Avatar
 
Join Date: Mar 2004
Posts: 8,484
I just bought 2 units of Xigmatex Tauro G 650 recently....

The PSU emits a humming sound, seems to be from the fan. It's like full blast even when idle / just turn on. Both units are like that, so I'm wondering if this is normal?

If it's not, do I have to bring all the cables for replacement? Or just the PSU will do?

Update:
Please bring both units with full set(all the cables.)
Our guys will check for you.
If faulty, they will replace for you.

Cheers.
__________________

-Local MSI product arrival/price updates: Kabylake/Ryzen
-MSI TwinFrozr Club! Come join our very own SG club!
=My Cooling=
TRU12E Cu LE / Vapo LS Singlestage /
SF3D Inflection Pt CPU pot + Ryba slim GPU pot ver.2

Last edited by clon22; Yesterday at 10:52 AM..
clon22 is online now   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On