HWZ Forums

Login Register FAQ Mark Forums Read

Connect TP Link Archer C7 to Starhub Fibre Broadband

Like Tree2Likes
Reply
 
LinkBack Thread Tools
Old 26-08-2017, 12:16 PM   #1
Junior Member
 
Join Date: Jan 2011
Posts: 7
Connect TP Link Archer C7 to Starhub Fibre Broadband

Any brothers can advise how to connect TP Link Archer C7 to Starhub fibre internet?

When I connect from the modem to C7, nothing happens - the internet icon on C7 does not light up at all. There is no internet at all.

But the modem works perfectly OK with the Starhub supplied DLink router.

My C7 is a Singapore version with warranty. I brought it back to the agent who tested it using his Starhub corporate internet and it works.

Any help is appreciated.
bemozart is offline   Reply With Quote
Old 26-08-2017, 12:38 PM   #2
Supremacy Member
 
xonix's Avatar
 
Join Date: Mar 2001
Posts: 9,720
1) What did you setup for C7 ? Automatic IP or something else e.g. PPPOE
2) Did you switch in C7 without turn off Starhub ONT first ?
__________________
WTS Blu Life One X 2016 (16g)
WTS Moto X 2013/2014 (32g)
WTS Moto X 2015 Brown Leather (32g)
xonix is offline   Reply With Quote
Old 26-08-2017, 02:20 PM   #3
Master Member
 
tungsten2's Avatar
 
Join Date: May 2000
Posts: 3,696
Any brothers can advise how to connect TP Link Archer C7 to Starhub fibre internet?

When I connect from the modem to C7, nothing happens - the internet icon on C7 does not light up at all. There is no internet at all.

But the modem works perfectly OK with the Starhub supplied DLink router.

My C7 is a Singapore version with warranty. I brought it back to the agent who tested it using his Starhub corporate internet and it works.

Any help is appreciated.
Its plug & play with SH.

1.Try perform a reset to factory default.

2.Change to OpenDNS

3. Disable DHCP v6

4. Check MTU is 1500

Sent from Samsung SM-G930F using GAGT
tungsten2 is offline   Reply With Quote
Old 26-08-2017, 02:45 PM   #4
Junior Member
 
Join Date: Jan 2011
Posts: 7
Thanks Tungsten2

I have done the factory reset but it still cannot connect.

How to do #2 to #4? Possible to provide a step by step guide coz I am very bad at this.

If #2 to #4 are done, can it still work with my Starhub supplied DLink router?

Many thanks
bemozart is offline   Reply With Quote
Old 26-08-2017, 03:26 PM   #5
Great Supremacy Member
 
chesterqw's Avatar
 
Join Date: Dec 2006
Posts: 55,804
are you connecting the c7 to port 1 of the huawei ONT?

edit:do you have direct ONT?
__________________
United Earth Federation

Xperia XZP
PC> Geek Pulse fi > DT 990 Pro

Last edited by chesterqw; 26-08-2017 at 03:52 PM..
chesterqw is offline   Reply With Quote
Old 26-08-2017, 03:50 PM   #6
High Supremacy Member
 
Ah-Pin-Kor's Avatar
 
Join Date: Apr 2008
Posts: 30,909
Any brothers can advise how to connect TP Link Archer C7 to Starhub fibre internet?

When I connect from the modem to C7, nothing happens - the internet icon on C7 does not light up at all. There is no internet at all.

But the modem works perfectly OK with the Starhub supplied DLink router.

My C7 is a Singapore version with warranty. I brought it back to the agent who tested it using his Starhub corporate internet and it works.

Any help is appreciated.
First of all what is the exact model of your DLink router?
If its the DVG-N5402SP then you need to request for direct ONT before using normal router.
chesterqw likes this.
Ah-Pin-Kor is offline   Reply With Quote
Old 26-08-2017, 03:50 PM   #7
Master Member
 
tungsten2's Avatar
 
Join Date: May 2000
Posts: 3,696
Thanks Tungsten2

I have done the factory reset but it still cannot connect.

How to do #2 to #4? Possible to provide a step by step guide coz I am very bad at this.

If #2 to #4 are done, can it still work with my Starhub supplied DLink router?

Many thanks


Pri : 208.67.222.123
Sec : 208.67.220.123

Remember to click the "Save" after changing the DNS


Yes, of course you can always use back the supplied DLink router

Refer to here to Disable IPv6 : http://www.tp-link.com/la/faq-852.html
tungsten2 is offline   Reply With Quote
Old 26-08-2017, 05:10 PM   #8
Junior Member
 
Join Date: Jan 2011
Posts: 7
My D-Link router is DIL 865L and it is working OK ie I can get internet access.

I do the following connection for TP-Link Archer C7 but cannot get internet access; therefore i cannot configure as suggested by Tungsten2:

1) Connect from Starhub huawei nucleus connect modem port 1 to blue internet port of C7
2) Connect from C7 ethernet orange port 1 to notebook

I called Starhub technical about Direct ONT and was told it doesn't matter.

I brought the C7 to the agent and he can connect to his modem to get internet access but I can't do it at home.

So, I suspect it must be the Starhub modem setting. Any brothers can advise? Thanks
bemozart is offline   Reply With Quote
Old 26-08-2017, 05:18 PM   #9
Great Supremacy Member
 
chesterqw's Avatar
 
Join Date: Dec 2006
Posts: 55,804
My D-Link router is DIL 865L and it is working OK ie I can get internet access.

I do the following connection for TP-Link Archer C7 but cannot get internet access; therefore i cannot configure as suggested by Tungsten2:

1) Connect from Starhub huawei nucleus connect modem port 1 to blue internet port of C7
2) Connect from C7 ethernet orange port 1 to notebook

I called Starhub technical about Direct ONT and was told it doesn't matter.

I brought the C7 to the agent and he can connect to his modem to get internet access but I can't do it at home.

So, I suspect it must be the Starhub modem setting. Any brothers can advise? Thanks
you can go to the settings of the c7 thru your laptop right?

the status got write anything?

if you go network tab
under network tab choose WAN
the WAN Connection Type is dynamic IP?
__________________
United Earth Federation

Xperia XZP
PC> Geek Pulse fi > DT 990 Pro
chesterqw is offline   Reply With Quote
Old 26-08-2017, 08:55 PM   #10
Senior Member
 
Join Date: Jun 2016
Posts: 899
Any brothers can advise how to connect TP Link Archer C7 to Starhub fibre internet?

When I connect from the modem to C7, nothing happens - the internet icon on C7 does not light up at all. There is no internet at all.

But the modem works perfectly OK with the Starhub supplied DLink router.

My C7 is a Singapore version with warranty. I brought it back to the agent who tested it using his Starhub corporate internet and it works.

Any help is appreciated.
Have u checkout the faq in their websites on ur situation.
Such as firmware upgrade, if any, as most set are not updated to latest firmware.

http://www.tp-link.com/us/download/Archer-C7.html#FAQs

Last edited by eric3743; 26-08-2017 at 09:00 PM..
eric3743 is offline   Reply With Quote
Old 26-08-2017, 10:30 PM   #11
Supremacy Member
 
Join Date: Jan 2000
Posts: 5,941
Your C7 router may be defective. Have you tried to test it with another broadband connection? E.g bring to your neighbour or friend's house to test.
koxinga is offline   Reply With Quote
Old 27-08-2017, 07:30 AM   #12
Junior Member
 
Join Date: Jan 2011
Posts: 7
Many thanks for all the replies.

1) My Starhub works perfectly with the Starhub-supplied DLink 865L.

2) My C7 is the US v4 bought with TP-link warranty. I brought it down to the agent and it tested OK - ie able to connect using the agent's ISP (Starhub). So I suppose the C7 is not faulty.

3) But when at home, it cannot be connected to the internet at all - not even via the ethernet cables and also no wireless connection. The internet icon on C7 is not lighted up at all.

4) One brother suggested Direct DNS - I called Starhub Technical Support and the answer is this is not the issue. My Starhub was contracted in December 2013.

I thought any router should work with any ISP but it seems I am wrong.
bemozart is offline   Reply With Quote
Old 27-08-2017, 10:16 AM   #13
Senior Member
 
Join Date: Jun 2016
Posts: 899
There is one settings u may have to changed.
IPv6 is disable in Dlink router.
Do check ur existing 865 on this.
And compare to the TP-link.
There was a similar issue in a similar model to yours regarding to this in the Starhub community forum.
U need to trial n error on this.

Sent from Seven Enlightenment using GAGT
eric3743 is offline   Reply With Quote
Old 28-08-2017, 12:28 PM   #14
Great Supremacy Member
 
chesterqw's Avatar
 
Join Date: Dec 2006
Posts: 55,804
Many thanks for all the replies.

1) My Starhub works perfectly with the Starhub-supplied DLink 865L.

2) My C7 is the US v4 bought with TP-link warranty. I brought it down to the agent and it tested OK - ie able to connect using the agent's ISP (Starhub). So I suppose the C7 is not faulty.

3) But when at home, it cannot be connected to the internet at all - not even via the ethernet cables and also no wireless connection. The internet icon on C7 is not lighted up at all.

4) One brother suggested Direct DNS - I called Starhub Technical Support and the answer is this is not the issue. My Starhub was contracted in December 2013.

I thought any router should work with any ISP but it seems I am wrong.

you can go to the settings of the c7 thru your laptop right?

the status got write anything?

if you go network tab
under network tab choose WAN
the WAN Connection Type is dynamic IP?


direct ONT not DNS.
__________________
United Earth Federation

Xperia XZP
PC> Geek Pulse fi > DT 990 Pro
chesterqw is offline   Reply With Quote
Old 29-08-2017, 04:42 PM   #15
Arch-Supremacy Member
 
wherehouse's Avatar
 
Join Date: Jan 2003
Posts: 13,612
Many thanks for all the replies.

1) My Starhub works perfectly with the Starhub-supplied DLink 865L.

2) My C7 is the US v4 bought with TP-link warranty. I brought it down to the agent and it tested OK - ie able to connect using the agent's ISP (Starhub). So I suppose the C7 is not faulty.

3) But when at home, it cannot be connected to the internet at all - not even via the ethernet cables and also no wireless connection. The internet icon on C7 is not lighted up at all.

4) One brother suggested Direct DNS - I called Starhub Technical Support and the answer is this is not the issue. My Starhub was contracted in December 2013.

I thought any router should work with any ISP but it seems I am wrong.
Suspect user problems.
unlpug the lan cable from the 865L wan port. connect it to the c7's wan port.
power off everything & power on again.
consumer router is generally plug and play.
__________________
Clear Green Dreams Fly Faster Than Plastic Ones
wherehouse is offline   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On