HWZ Forums

Login Register FAQ Mark Forums Read

How to enable all ports in Asus RT-AC5300 (For Singtel Fibre Broadband)

Like Tree1Likes
  • 1 Post By terencenhk
Reply
 
LinkBack Thread Tools
Old 27-07-2016, 10:53 AM   #1
Junior Member
 
Join Date: Jul 2016
Posts: 7
Smile How to enable all ports in Asus RT-AC5300 (For Singtel Fibre Broadband)

Hi All,

This is my setup
i2.photobucket.com/albums/y25/TerenceNHK/Forum/NHK%20Home%20Cloud%20Public.jpg

I don't really want to install another 1G switch if I just need 1 more LAN port.

Currently I am using "Singtel-Others" the ISP Profile under "LAN > IPTV", everything is working fine, I can access internet, number 1-3 ports are working well except for the LAN port 4.

Understand that LAN port 4 will be reserved for "IPTV STB Port" purpose , but due to I am no longer using IP TV, is there a way I can configure port 4 back to the normal, so that I can use it for other equipment (example: PC).

If I set the "ISP Profile" to "None", will it also remove the VLAN Tagging settings that lead to no internet access?

If I use "Manual Setting" ISP profile, what should I set for the below:?
- Internet VID 10 PRIO 0
- LAN port 4 VID 20 PRIO 4
- LAN port 4 VID 0 PRIO 0

Appreciate if anyone here can assist me on this issue.

Thank you in advance!

Regards,
Terence
terencenhk is offline   Reply With Quote
Old 27-07-2016, 10:56 AM   #2
Junior Member
 
Join Date: Jul 2016
Posts: 7
Can commands below works? (Via Telnet)
nvram set switch_stb_x=0
nvram commit
reboot
terencenhk is offline   Reply With Quote
Old 27-07-2016, 10:59 AM   #3
Arch-Supremacy Member
 
renfred89's Avatar
 
Join Date: Nov 2007
Posts: 14,644
Hi All,

This is my setup
i2.photobucket.com/albums/y25/TerenceNHK/Forum/NHK%20Home%20Cloud%20Public.jpg

I don't really want to install another 1G switch if I just need 1 more LAN port.

Currently I am using "Singtel-Others" the ISP Profile under "LAN > IPTV", everything is working fine, I can access internet, number 1-3 ports are working well except for the LAN port 4.

Understand that LAN port 4 will be reserved for "IPTV STB Port" purpose , but due to I am no longer using IP TV, is there a way I can configure port 4 back to the normal, so that I can use it for other equipment (example: PC).

If I set the "ISP Profile" to "None", will it also remove the VLAN Tagging settings that lead to no internet access?

If I use "Manual Setting" ISP profile, what should I set for the below:?
- Internet VID 10 PRIO 0
- LAN port 4 VID 20 PRIO 4
- LAN port 4 VID 0 PRIO 0

Appreciate if anyone here can assist me on this issue.

Thank you in advance!

Regards,
Terence
don't use telnet command if you are unsure..

in manual profile, set the following:

Internet ID-10 PRIO 0

Port 3 & 4 ID 0 PRIO 0

if the above doesn't work, leave the value in port 3 and 4 blank then save it. do rmb to do a reboot afterwards
renfred89 is offline   Reply With Quote
Old 27-07-2016, 11:34 AM   #4
Junior Member
 
Join Date: Jul 2016
Posts: 7
Smile

don't use telnet command if you are unsure..

in manual profile, set the following:

Internet ID-10 PRIO 0

Port 3 & 4 ID 0 PRIO 0

if the above doesn't work, leave the value in port 3 and 4 blank then save it. do rmb to do a reboot afterwards
Thanks for efficient fast reply~

I have changed the settings as shown below, doesn't work, error message pop out "Please enter a value between 2 to 4094"
- Internet ID-10 PRIO 0
- Port 4 ID 0 PRIO 0
- Port 3 ID 0 PRIO 0

May I know should I enter "10" or "-10" to the Internet VID field?

So then I set, yes, it allowed me to save, router then rebooting.
- Internet ID 10 PRIO 0
- Port 4 ID "empty" PRIO "empty"
- Port 3 ID "empty" PRIO "empty"

Result:
- Internet is working: as I am working in the office, controlling my router remotely, I can still login after 5 mins router rebooted.
- Port 1 and 2 is working: I have configured IEEE 802.3ad for my NAS, and I can access my NAS remotely.
- Port 3 is working: It is connected with my Apple Time Capsule, and I can access it remotely.
- Port 4, not sure: I will check it out and post the result tonight.

Anyway thanks so much, renfred89.

Regards,
Terence
terencenhk is offline   Reply With Quote
Old 27-07-2016, 12:11 PM   #5
Arch-Supremacy Member
 
renfred89's Avatar
 
Join Date: Nov 2007
Posts: 14,644
Thanks for efficient fast reply~

I have changed the settings as shown below, doesn't work, error message pop out "Please enter a value between 2 to 4094"
- Internet ID-10 PRIO 0
- Port 4 ID 0 PRIO 0
- Port 3 ID 0 PRIO 0

May I know should I enter "10" or "-10" to the Internet VID field?

So then I set, yes, it allowed me to save, router then rebooting.
- Internet ID 10 PRIO 0
- Port 4 ID "empty" PRIO "empty"
- Port 3 ID "empty" PRIO "empty"

Result:
- Internet is working: as I am working in the office, controlling my router remotely, I can still login after 5 mins router rebooted.
- Port 1 and 2 is working: I have configured IEEE 802.3ad for my NAS, and I can access my NAS remotely.
- Port 3 is working: It is connected with my Apple Time Capsule, and I can access it remotely.
- Port 4, not sure: I will check it out and post the result tonight.

Anyway thanks so much, renfred89.

Regards,
Terence
yes just a value 10 will do. there was a period of time when asus firmware doesn't recognise an input of 0, so i'm not sure if it works by entering 0. if its left blank, then if it allows u to save, then its likely to work..
renfred89 is offline   Reply With Quote
Old 27-07-2016, 04:29 PM   #6
Junior Member
 
Join Date: Jul 2016
Posts: 7
yes just a value 10 will do. there was a period of time when asus firmware doesn't recognise an input of 0, so i'm not sure if it works by entering 0. if its left blank, then if it allows u to save, then its likely to work..
I just received reply from official ASUS support.

They sent me the commands which are exactly same as someone posted in this forum.
nvram set switch_stb_x=0
nvram commit
reboot

I will try it out tonight and post the result.

Thanks guy.

Last edited by terencenhk; 27-07-2016 at 04:38 PM..
terencenhk is offline   Reply With Quote
Old 28-07-2016, 07:45 AM   #7
Junior Member
 
Join Date: Jul 2016
Posts: 7
I didn't use the telnet commands but only "empty" the LAN 3 and LAN 4 fields, tested and confirmed.

Work like a charm~
siczano likes this.
terencenhk is offline   Reply With Quote
Old 12-01-2018, 12:31 PM   #8
Junior Member
 
Join Date: Feb 2012
Posts: 42
I've been having the same exact problem with my asus RT AC5300. Thank you for the tips terencenhk for fixing this issue. LAN 3 & 4 ports work well on my devices. THANK YOU!
siczano is offline   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On