HWZ Forums

Login Register FAQ Mark Forums Read

Recommendation: Reliable workshops in JB

Like Tree428Likes
Reply
 
LinkBack Thread Tools
Old 23-01-2018, 02:32 PM   #1756
Senior Member
 
Join Date: May 2009
Posts: 2,070
Wow!! None of the other workshops spotted this??
Not even the 'so-called' specialist you went to?
Amazing...... @,@
Yes.. sometimes such minor things can cause much inconvenience, time and money wasted 😭
lightsticks is offline   Reply With Quote
Old 23-01-2018, 02:40 PM   #1757
High Supremacy Member
 
Join Date: Jul 2014
Posts: 27,335
Finally the sound is gone. Was in Jb last Sunday, drop by at LCH Brother to check.. went for a test drive and was told that the top and bottom clip on the pads is missing. Went to get the clips and replace by him.. now so far so good.. 😊😊😊 thanks bros for the help
was it ah yuan who fixed the prob for u? that guy is pretty good.
koolaid is offline   Reply With Quote
Old 23-01-2018, 03:46 PM   #1758
Senior Member
 
Join Date: May 2009
Posts: 2,070
was it ah yuan who fixed the prob for u? that guy is pretty good.
Yes. It was Sunday and only LCH and YS is opened. I look for ah yuan.. he went for a test drive 5 mins and tell me is the missing little clip that cause the noise. Pretty good compared to shops that hoist up the car for few hours canít solve it
lightsticks is offline   Reply With Quote
Old 23-01-2018, 03:56 PM   #1759
High Supremacy Member
 
snipfer's Avatar
 
Join Date: Jan 2009
Posts: 25,044
Good to hear the problem solved.
It's the experience that counts.
Doing oil change, replacement of parts is easy but not diagnosis

Sent from Xiaomi MI MAX 2 Inside a Cherry Kill Kill using GAGT
snipfer is offline   Reply With Quote
Old 23-01-2018, 04:33 PM   #1760
High Supremacy Member
 
Join Date: Jul 2014
Posts: 27,335
Yes. It was Sunday and only LCH and YS is opened. I look for ah yuan.. he went for a test drive 5 mins and tell me is the missing little clip that cause the noise. Pretty good compared to shops that hoist up the car for few hours canít solve it
nice... glad to hear that the brake noise issue is solved.
koolaid is offline   Reply With Quote
Old 23-01-2018, 09:57 PM   #1761
Member
 
Join Date: Aug 2005
Posts: 254
Finally the sound is gone. Was in Jb last Sunday, drop by at LCH Brother to check.. went for a test drive and was told that the top and bottom clip on the pads is missing. Went to get the clips and replace by him.. now so far so good.. ****************************************************** thanks bros for the help
Wah...my small japanese car also got sound when braking and reversing braking....
mine with wilwood after market caliper....guess got to look for ah yuan lor
Bond388 is offline   Reply With Quote
Old 23-01-2018, 10:34 PM   #1762
High Supremacy Member
 
Join Date: Jul 2014
Posts: 27,335
Wah...my small japanese car also got sound when braking and reversing braking....
mine with wilwood after market caliper....guess got to look for ah yuan lor
ya... always good to msg him b4 u go...
koolaid is offline   Reply With Quote
Old 26-01-2018, 08:56 PM   #1763
Supremacy Member
 
Join Date: Nov 2005
Posts: 8,783
i have a problem.. few weeks ago, the oil pressure warning light(Aladdin lamp) starts to flicker during idling(once i stopped the car after parking). i quickly switch off the engine and on again and the flickering stops. everything back to normal.

few days ago, the flickering of oil pressure warning light came back when i started my car(car was used less than 30mins ago, so eliminating low temperature cause). switch off and check engine oil level - at the correct level. switch on the engine again and it still flickers. dont know why but i decided to step on the accelerator abit to rev the engine and the flickering stops.

the flickering came on more and more often but always disappear when i rev or the car is moving, meaning, the flickering comes when the engine is idle.

anyone know whats the probable cause? Is this issue critical or just sensor heywire and i can continue to drive and live with it till next servicing?

Does LCH carries OBD2 (On-board-diagnostics) ? I'm thinking of going back to them to let them check because i just did my servicing from them in late Dec. Or you guys think i should settle it in Singapore?

thanks
skai_11 is offline   Reply With Quote
Old 26-01-2018, 11:59 PM   #1764
High Supremacy Member
 
snipfer's Avatar
 
Join Date: Jan 2009
Posts: 25,044
Sounds like sensor

Sent from Xiaomi MI MAX 2 using GAGT
snipfer is offline   Reply With Quote
Old 27-01-2018, 05:37 AM   #1765
High Supremacy Member
 
Join Date: Jul 2014
Posts: 27,335
could be a few things...

check ur dipstick properly to see if oil level is low... check the level in the morning b4 u start the engine and check again after u start the engine for 10 to 15 mintues. if the level is below or at the low indicator, top up the eo accordingly. could be an oil leak somewhere.

if the oil level is good, it could be the oil pump not working properly...

most mechs will have odb2 scanner in their workshop.
koolaid is offline   Reply With Quote
Old 27-01-2018, 10:14 AM   #1766
Master Member
 
Join Date: Sep 2017
Posts: 2,743
I would get it checked locally first.
What if really the O.P not working properly and during the long ride to JB would do more harm to the entire engine.
myviowner is offline   Reply With Quote
Old 27-01-2018, 11:22 PM   #1767
High Supremacy Member
 
Join Date: Jul 2005
Posts: 44,907
Just had a gear problem.

Auto gear shifting no matter what still show N

What the likely cause ?
Car cannot move when step gas pedal

Issit a fuse blown or switch cable gone case.

Just hope is not gearbox uplorry

Last edited by sentsggirls; 27-01-2018 at 11:28 PM..
sentsggirls is offline   Reply With Quote
Old 27-01-2018, 11:39 PM   #1768
High Supremacy Member
 
Join Date: Jul 2014
Posts: 27,335
Just had a gear problem.

Auto gear shifting no matter what still show N

What the likely cause ?
Car cannot move when step gas pedal

Issit a fuse blown or switch cable gone case.

Just hope is not gearbox uplorry
auto or manual?
koolaid is offline   Reply With Quote
Old 28-01-2018, 12:05 AM   #1769
High Supremacy Member
 
Join Date: Jul 2005
Posts: 44,907
auto or manual?
Auto bro.

They already tow my car from Miti-carpark.

Very worry now

Selector linkage or downshift cable gone case ?
But my engine can on and off. Just that it stay on neural gear.
sentsggirls is offline   Reply With Quote
Old 28-01-2018, 12:55 AM   #1770
High Supremacy Member
 
Join Date: Jul 2014
Posts: 27,335
Auto bro.

They already tow my car from Miti-carpark.

Very worry now

Selector linkage or downshift cable gone case ?
But my engine can on and off. Just that it stay on neural gear.
ya... very likely culprits are the cable or linkage... either need to replace becos it snapped or just need some adjustment...

sometimes tranny fluid low may have this prob as well...

dont think the engine has probs.
koolaid is offline   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On