HWZ Forums

Login Register FAQ Mark Forums Read

GPU RGB cannot light up

Like Tree1Likes
  • 1 Post By clon22
Reply
 
LinkBack Thread Tools
Old 18-03-2019, 02:33 PM   #1
Arch-Supremacy Member
 
ethan89's Avatar
 
Join Date: Jan 2015
Posts: 14,721
Unhappy GPU RGB cannot light up

Hi Corbell,

I've purchased the MSI RTX 2080 Gaming X Trio about a month or two ago.

Just finished building my rig and to my unpleasant surprise, I realised its RGB LEDs can't light up no matter how I install/uninstall Mystic Light.

However, the GPU is detected on my system and seems to be working fine during gaming (just tried for 10-15 mins loading into a game).

I'm not a pro myself so I didn't try to use advanced tools to do benchmarks or whatsoever to diagnose if there's any other possible defects.

May I seek your assistance on this?

Thank you
__________________
"Our growth depends not on how many experiences we devour, but on how many we digest."
- Sockman

Last edited by ethan89; 18-03-2019 at 02:36 PM..
ethan89 is offline   Reply With Quote
Old 18-03-2019, 02:44 PM   #2
Featured Distributor for Hardware Clinic, Storage Clinic
 
clon22's Avatar
 
Join Date: Mar 2004
Posts: 8,908
Hi Corbell,

I've purchased the MSI RTX 2080 Gaming X Trio about a month or two ago.

Just finished building my rig and to my unpleasant surprise, I realised its RGB LEDs can't light up no matter how I install/uninstall Mystic Light.

However, the GPU is detected on my system and seems to be working fine during gaming (just tried for 10-15 mins loading into a game).

I'm not a pro myself so I didn't try to use advanced tools to do benchmarks or whatsoever to diagnose if there's any other possible defects.

May I seek your assistance on this?

Thank you
The LED lights up upon powering up.
So you there should be lights by default.
If you had off them via s/w, just on it again.
Otherwise, you can being the card down for a check.
__________________

-Local MSI product arrival/price updates: Kabylake/Ryzen
-MSI TwinFrozr Club! Come join our very own SG club!
=My Cooling=
TRU12E Cu LE / Vapo LS Singlestage /
SF3D Inflection Pt CPU pot + Ryba slim GPU pot ver.2
clon22 is offline   Reply With Quote
Old 18-03-2019, 04:10 PM   #3
Arch-Supremacy Member
 
ethan89's Avatar
 
Join Date: Jan 2015
Posts: 14,721
The LED lights up upon powering up.
So you there should be lights by default.
If you had off them via s/w, just on it again.
Otherwise, you can being the card down for a check.
I see.

Well it has never lighted up since I first start my rig up... Never meddle with any software settings as well... So not sure what went wrong.

Will be bringing it down to your service centre sometime this week. Is it Blk 4012 AMK Ave 10 #06-04?
__________________
"Our growth depends not on how many experiences we devour, but on how many we digest."
- Sockman
ethan89 is offline   Reply With Quote
Old 18-03-2019, 06:23 PM   #4
Featured Distributor for Hardware Clinic, Storage Clinic
 
clon22's Avatar
 
Join Date: Mar 2004
Posts: 8,908
I see.

Well it has never lighted up since I first start my rig up... Never meddle with any software settings as well... So not sure what went wrong.

Will be bringing it down to your service centre sometime this week. Is it Blk 4012 AMK Ave 10 #06-04?
Yup, just bring in over.
We'll test and change for you if faulty.
ethan89 likes this.
__________________

-Local MSI product arrival/price updates: Kabylake/Ryzen
-MSI TwinFrozr Club! Come join our very own SG club!
=My Cooling=
TRU12E Cu LE / Vapo LS Singlestage /
SF3D Inflection Pt CPU pot + Ryba slim GPU pot ver.2
clon22 is offline   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On