HWZ Forums

Login Register FAQ Mark Forums Read

Assassin Creed Odyssey

Reply
 
LinkBack Thread Tools
Old 19-11-2018, 10:17 AM   #1
Senior Member
 
Join Date: Jul 2016
Posts: 1,482
Assassin Creed Odyssey

Hi, anyone playing this game on PC? how is the fps? mine using 1080ti and 8700k and the fps move around erratically between 30 - 80fps. it makes the game stuttery and very annoying.

any bros / gurus have any tweak / fix for this?

I have tried the following:
1. Max pre-rendered set to 1
2. Disabled fullscreen optimization.
3. even tried setting the overall graphic to MEDIUM(only increase max fps. but still jump around 30fps to 100fps. mostly below 60fps)
4. Tried both fullscreen / borderless...not much different.
5. Power option set to full performance
6. Disabled MFAA

i did ask in reddit and some says no issues with constant 70fps..some say its bullfaeces and the only way to eliminate the stutter and erratic fps is to limit the fps to 30 using rivatuner.
CrispyPeddler is online now   Reply With Quote
Old 19-11-2018, 10:23 AM   #2
Greater Supremacy Member
 
Swordsman's Avatar
 
Join Date: Jan 2002
Posts: 80,491
thats why many people play on console. no need to headache over such stuff but also won't get to enjoy 60 fps.
__________________
Single is not a status.

It's a word that describes a person who is strong enough to enjoy life alone.
Swordsman is offline   Reply With Quote
Old 19-11-2018, 11:18 AM   #3
Senior Member
 
Join Date: Jul 2016
Posts: 1,482
thats why many people play on console. no need to headache over such stuff but also won't get to enjoy 60 fps.
now with pc also need to limit it to 30fps...like console..fml
CrispyPeddler is online now   Reply With Quote
Old 19-11-2018, 12:19 PM   #4
Master Member
 
Join Date: Apr 2003
Posts: 4,128
I have similar issues with GTA 5, even with an i7 and a 1080. Not sure what other settings we are missing. It tends to get better after being in that area for a while.

Sent from HUAWEI CLT-L29 using GAGT
fi5hbone is offline   Reply With Quote
Old 19-11-2018, 03:00 PM   #5
Senior Member
 
Join Date: Jul 2016
Posts: 1,482
I have similar issues with GTA 5, even with an i7 and a 1080. Not sure what other settings we are missing. It tends to get better after being in that area for a while.

Sent from HUAWEI CLT-L29 using GAGT
sigh. so there is no fix for this ACO to be play in constant 60fps+ at 1440p with 1080ti darrnit
CrispyPeddler is online now   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On