HWZ Forums

Login Register FAQ Mark Forums Read

Jabra Elite Active 65t

Like Tree1Likes
Reply
 
LinkBack Thread Tools
Old 21-12-2018, 10:16 PM   #61
Supremacy Member
 
Immortal's Avatar
 
Join Date: Mar 2013
Posts: 6,501
what diameter to get for the elite 65 t?
I just got those that were on Amazon recommendation.
Immortal is online now   Reply With Quote
Old 26-12-2018, 10:44 PM   #62
Junior Member
 
Idexzz's Avatar
 
Join Date: Dec 2018
Posts: 16
Good stuff. Even better after i changed the stock tips with comply foam tips.
Any recommendations on where to get compatible comply foam tips?
Idexzz is offline   Reply With Quote
Old 27-12-2018, 09:32 AM   #63
Supremacy Member
 
Immortal's Avatar
 
Join Date: Mar 2013
Posts: 6,501
Any recommendations on where to get compatible comply foam tips?
Amazon Recommendation.

But a bit difficult to fit into charger box.
Idexzz likes this.
Immortal is online now   Reply With Quote
Old 27-12-2018, 08:48 PM   #64
Junior Member
 
Join Date: Oct 2017
Posts: 5
Just got the Jabra Elite active 65T earbuds yesterday from Amazon US and already experiencing problems.

1) Hissing or soft static sound on the left ear bud, about 2 seconds before and after I play pause music.

2) Audio either cracks or sound horrible when the bass is heavy. My volume is around 70-80% on my iphone and no matter how i tune the EQ the cracks and bad quality is still there.
Click or some weird sound when I up or down the volume around that range. It sounds a lot better when i connect to my mba tho...
SOLVED --> I didn't realise my spotify was on "low" quality, once i switched to normal or high, IT SOUNDS PERFECT.

3) When I tilt my head up to stretch my neck, the left ear bud completely goes silent. Music comes back again when I tilt back to normal.

If I can solve these issues, I would say the earbuds are quite good. Comfort level wise, it's very subjective. My ear canals are not the same size fml. So one is comfortable while the other is uncomfortable.

I've done the firmware update, re-pair the earbuds and everything as suggested by Jabra's support center, but the problem still persists.

Anyone facing the same issue? Or I just suay to receive a faulty set...

Last edited by kai123456; 28-12-2018 at 07:14 PM.. Reason: solved 1 issue
kai123456 is offline   Reply With Quote
Old 27-12-2018, 11:14 PM   #65
Supremacy Member
 
Immortal's Avatar
 
Join Date: Mar 2013
Posts: 6,501
Just got the Jabra Elite active 65T earbuds yesterday from Amazon US and already experiencing problems.

1) Hissing or soft static sound on the left ear bud, about 2 seconds before and after I play pause music.

2) Audio either cracks or sound horrible when the bass is heavy. My volume is around 70-80% on my iphone and no matter how i tune the EQ the cracks and bad quality is still there.
Click or some weird sound when I up or down the volume around that range. It sounds a lot better when i connect to my mba tho...

3) When I tilt my head up to stretch my neck, the left ear bud completely goes silent. Music comes back again when I tilt back to normal.

If I can solve these issues, I would say the earbuds are quite good. Comfort level wise, it's very subjective. My ear canals are not the same size fml. So one is comfortable while the other is uncomfortable.

I've done the firmware update, re-pair the earbuds and everything as suggested by Jabra's support center, but the problem still persists.

Anyone facing the same issue? Or I just suay to receive a faulty set...
Don't have such issues at all.

You tried re-pairing ? Or got some magnetic fields disturbance ?

Mine when near ezlink tap points will have some static.
Immortal is online now   Reply With Quote
Old 28-12-2018, 12:06 AM   #66
Junior Member
 
Join Date: Oct 2017
Posts: 5
Don't have such issues at all.

You tried re-pairing ? Or got some magnetic fields disturbance ?

Mine when near ezlink tap points will have some static.
I tried re-pairing and did the "forget this device" work around... no improvements.

I think i'm a walking maget. sighh...
kai123456 is offline   Reply With Quote
Old 28-12-2018, 10:36 AM   #67
Junior Member
 
Join Date: May 2013
Posts: 5
How is it compare with Bose soundsport free in terms of audio quality? I am deciding between the 2.
ivan07 is offline   Reply With Quote
Old 28-12-2018, 11:17 AM   #68
Member
 
Join Date: May 2013
Posts: 126
have u tried to update it with the new firmware? I do notice when u taking bus near the exit there is static and lost of left bud connection i guess is due to some wireless "thing" emit by the security camera
Legionchaos is offline   Reply With Quote
Old 28-12-2018, 03:52 PM   #69
High Supremacy Member
 
JAson1980's Avatar
 
Join Date: Feb 2006
Posts: 32,093
just got my ear bud yest.
any one feel the midsize earbud gel too small and the large one too big?

the large one create a vaccumn which rather uncomfort and the midsize like not fitting.

Get comply foam tips.. fit all ear size.
__________________
Agent for 30 successful Pedobear Singapore PR applications.
JAson1980 is offline   Reply With Quote
Old 28-12-2018, 03:56 PM   #70
High Supremacy Member
 
JAson1980's Avatar
 
Join Date: Feb 2006
Posts: 32,093
https://www.qoo10.sg/item/APPLY-18-M...ner_no=1305330

$229 on Qoo10 but export set.
__________________
Agent for 30 successful Pedobear Singapore PR applications.
JAson1980 is offline   Reply With Quote
Old 28-12-2018, 05:34 PM   #71
Junior Member
 
Join Date: Oct 2018
Posts: 70
I have the active 65T (blue) paired with iphone7 and ios12. so far no issues

try to pair to another phone to isolate if issue is with phone bluetooth

Just got the Jabra Elite active 65T earbuds yesterday from Amazon US and already experiencing problems.

1) Hissing or soft static sound on the left ear bud, about 2 seconds before and after I play pause music.

2) Audio either cracks or sound horrible when the bass is heavy. My volume is around 70-80% on my iphone and no matter how i tune the EQ the cracks and bad quality is still there.
Click or some weird sound when I up or down the volume around that range. It sounds a lot better when i connect to my mba tho...

3) When I tilt my head up to stretch my neck, the left ear bud completely goes silent. Music comes back again when I tilt back to normal.

If I can solve these issues, I would say the earbuds are quite good. Comfort level wise, it's very subjective. My ear canals are not the same size fml. So one is comfortable while the other is uncomfortable.

I've done the firmware update, re-pair the earbuds and everything as suggested by Jabra's support center, but the problem still persists.

Anyone facing the same issue? Or I just suay to receive a faulty set...
warehaws is offline   Reply With Quote
Old 28-12-2018, 07:13 PM   #72
Junior Member
 
Join Date: Oct 2017
Posts: 5
have u tried to update it with the new firmware? I do notice when u taking bus near the exit there is static and lost of left bud connection i guess is due to some wireless "thing" emit by the security camera
YEAH! I just noticed today, was sitting beside the exit door and suddenly no more left earbud connection. The MRT too, but it was just a short slight silent when walking through the doors, i guess the motion sensor is disrupting too.
kai123456 is offline   Reply With Quote
Old 28-12-2018, 07:16 PM   #73
Junior Member
 
Join Date: Oct 2017
Posts: 5
I have the active 65T (blue) paired with iphone7 and ios12. so far no issues

try to pair to another phone to isolate if issue is with phone bluetooth
I'll try that, and yeah i suspect it's something to do with my phone's bluetooth too.

Anyways, I just figured out the bad quality sound comes from my spotify setting! I just switched to normal or high quality and IT SOUNDS GOOD FINALLY.
kai123456 is offline   Reply With Quote
Old 29-12-2018, 12:03 AM   #74
Supremacy Member
 
Immortal's Avatar
 
Join Date: Mar 2013
Posts: 6,501
Get comply foam tips.. fit all ear size.
Went back to try the default buds that came with it. Used the largest 1 and it fits well enough for a jog.

No issues with the charging box as well. Comply foam tips still a wee bit better (sound & isolation)
Immortal is online now   Reply With Quote
Old 29-12-2018, 04:41 PM   #75
Member
 
Join Date: Mar 2009
Posts: 136
Some are saying that there is no lag while watching videos like Youtube etc..

Is this true? Saw some reviews which says that there is lag.
ran_1610 is offline   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On