www.hardwarezone.com.sg

www.hardwarezone.com.sg (/)
-   Internet Bandwidth & Networking Clinic (https://forums.hardwarezone.com.sg/internet-bandwidth-networking-clinic-4/)
-   -   Dlink 868L AP Mode causing wifi authentication issues (https://forums.hardwarezone.com.sg/internet-bandwidth-networking-clinic-4/dlink-868l-ap-mode-causing-wifi-authentication-issues-6109304.html)

aaaaarrrgghhh 08-09-2019 02:55 PM

Dlink 868L AP Mode causing wifi authentication issues
 
Hi,
In order to avoid poor wifi coverage,i'm trying to configure an AP.
I have SH fiber ONT connected to DlinkPrimary's WAN port. From DLinkPrimary LAN port, I have a cable going to my study, into a DLinkSecondary's LAN port.
DlinkPrimary has SSID 'HomeNet' at 2.4GHz, and does the DHCP.
DlinkSecondary is in BridgeMode (acts like an AP).Its also configured for Wireless 2.4GHz, same SSID, AES cipher and password as DLinkPrimary.

As soon as i power on DlinkSecondary, wifi clients can no longer connect to the SSID - either they just try to connect and go back to just saying "Saved", or give a message saying "Authentication error occurred". if I switch off DLinkSecondary wireless, clients can connect.

My 5GHz network from DLinkPrimary continues happily.

DLink Primary Settings:
Wireless Security Mode = WPA-Personal
WPA Mode = Auto(WPA or WPA2)

DLink Secondary Settings:
I've tried both WPA and WPA2.

Both 868L routers are at the 1.12 F/W version, A1 H/W version.

Any pointers to troubleshoot this?

uncle_josh 08-09-2019 03:18 PM

Follow the guide here : DIR-868L How To Setup Access Point (AP) For Router ?

As you can see there is not need to set any WPA or WPA2 on the AP.
It will auto grab all the necessary from the Primary Router.
All you just have to do is wait for 10 or 15 minutes.

aaaaarrrgghhh 08-09-2019 07:58 PM

Quote:

Originally Posted by uncle_josh (Post 122658713)
Follow the guide here : DIR-868L How To Setup Access Point (AP) For Router ?

As you can see there is not need to set any WPA or WPA2 on the AP.
It will auto grab all the necessary from the Primary Router.
All you just have to do is wait for 10 or 15 minutes.

Thanks, I did look at that doc. 2 issues with the doc:
1.Strangely, my router's Internet page only has a checkbox for "Enable Bridge Mode" - no dropdown with the other options shown there.Apparently this Bridge mode is the AP mode. I've also selected Static IP and not DHCP.

2.The doc doesn't say anything about wireless at all - I need to use it as wireless AP, and when I enable wireless checkbox on the DLinkSecondary in Wireless Settings, I necessarily have to select the SSID, security mode and cipher. Unless I select wireless, the AP is just a LAN extension.

uncle_josh 08-09-2019 08:30 PM

Pls use the Starhub firmware
This router works best with Starhub firmware !!!

aaaaarrrgghhh 08-09-2019 08:41 PM

Quote:

Originally Posted by uncle_josh (Post 122662942)
Pls use the Starhub firmware
This router works best with Starhub firmware !!!

oh cool - thanks for that! downloading now.

AMAT 08-09-2019 09:27 PM

Not sure what you really want to do, AP only for LAN or AP for wireless roaming, and why not using 5ghz ?

If wireless roaming need to set to different channel from primary router.

Also, to upgrade to 1.21,need to factory reset first, then upgrade to 1.10 (the middle one) , wait 5 mins, then upgrade to 1.21, wait 5 mins ,then configure as AP or wireless AP.

aaaaarrrgghhh 08-09-2019 09:44 PM

Quote:

Originally Posted by aaaaarrrgghhh (Post 122663073)
oh cool - thanks for that! downloading now.

shucks - routers bricked with that update. I can't change anything in the router..get all sorts of Internal error messages.
rollback!

uncle_josh 08-09-2019 10:30 PM

Screenshot your errors !!!

Go to here : D-Link DIR-868L - DD-WRT Wiki, search for Recovery Mode, somewhere in the middle. Follow the instruction closely.

aaaaarrrgghhh 09-09-2019 11:13 AM

Quote:

Originally Posted by uncle_josh (Post 122664749)
Screenshot your errors !!!

Go to here : D-Link DIR-868L - DD-WRT Wiki, search for Recovery Mode, somewhere in the middle. Follow the instruction closely.

Thanks - I had already seen another thread on HWZ about the recovery mode and was struggling with it- but using Firefox was the key input from this link!
Anyway - after a whole lot of heartburn, both routers are up and running with 1.21SHC.
I followed the Wireless AP method (can see the drop down now!), but the wireless networks created by the AP are the default DLink ones - is that how it is supposed to work, or should I rename the wireless networks on the AP to match the ones on the Primary?

aaaaarrrgghhh 09-09-2019 11:43 AM

Quote:

Originally Posted by aaaaarrrgghhh (Post 122670149)
Thanks - I had already seen another thread on HWZ about the recovery mode and was struggling with it- but using Firefox was the key input from this link!
Anyway - after a whole lot of heartburn, both routers are up and running with 1.21SHC.
I followed the Wireless AP method (can see the drop down now!), but the wireless networks created by the AP are the default DLink ones - is that how it is supposed to work, or should I rename the wireless networks on the AP to match the ones on the Primary?


oh well - i just matched the wireless settings on the AP -and everything works now!
Thanks for a lot for your help folks!

uncle_josh 09-09-2019 12:37 PM

Congrats !!!

Sent from 今天工作不努力, 明天努力找工作 using GAGT


All times are GMT +8. The time now is 12:21 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright © SPH Magazines Pte Ltd. All rights reserved.