HWZ Forums

Login Register FAQ Mark Forums Read

Wireguard setup

Reply
 
LinkBack Thread Tools
Old 28-02-2020, 12:44 PM   #1
Member
 
Join Date: Nov 2003
Posts: 203
Wireguard setup

Hi guys,

Experimenting with wireguard, and i could not get to work.
I am using Singtel Pace FG7009GR and ubuntu as server.
This script is provided by angristan.
Somehow i can connect but cannot surf on my iphone.. is there anything i missed out?

root@asus:/home/me# bash wireguard-install.sh IPv4 or IPv6 public address: 1.2.3.4 Public interface: eth0 WireGuard interface name: wg0 Server's WireGuard IPv4 198.168.1.10 Server's WireGuard IPv6 fd42:42:42::1 Server's WireGuard port 51820 Client's WireGuard IPv4 198.168.1.50 Client's WireGuard IPv6 fd42:42:42::2 First DNS resolver to use for the client: 8.8.8.8 Second DNS resolver to use for the client: 1.1.1.1 Want to use a pre-shared symmetric key? [Y/n]: y


* is "Public interface" referring which port my server is connected to the router?
* "Server's WireGuard IPv4" refer to my server's ip?
* "Client's WireGuard IPv4" is this the next available ip address in my router?
* previously i tried to adding 198.168.2.1. looks like router not able to handle it
absoluthk is offline   Reply With Quote
Old 01-03-2020, 01:21 AM   #2
Member
 
Join Date: Nov 2003
Posts: 203
For anyone using angristan's script for their home network

somehow this command didnt run in the script, try running it

root@asus:~# systemctl start wg-quick@wg0
Second
Singtel router dont use IPv6, safe to remove from both server and client conf

Third
reduce this range.. slash 24 is too much for home router

server:192.168.1.10 slash 32
client:192.168.1.51 slash 32
absoluthk is offline   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On