HWZ Forums

Login Register FAQ Mark Forums Read

working Singtel Vlan Settings with TPLink SG108E

Like Tree4Likes
Reply
 
LinkBack Thread Tools
Old 25-12-2017, 01:07 PM   #1
Master Member
 
Join Date: Jan 2002
Posts: 3,271
working Singtel Vlan Settings with TPLink SG108E

Creating a new post to share with folks here.

Setup to get t Singtel Internet and IPTV working with 3rd Party Router (Without Vlan Support) with TP-Link SG108E Easy smart switch in Between ONT and Router .

Previous many have reported issues to work with the TPLink Easy Smart Switch.

Before this ,I have read many post here and many reported TP-link managed switch is not compatible with 802.1p priority setting and therefore cant get IPTV to work and Internet is also intermittent.

Below is setup I have done and initially also cant get it working with reference from many posts here but luck come in.


I did a reset to managed Switch and do a fresh setup and magically my notebook started to receive DHCP with IP address allocation on my ONT-> Switch-> Notebook LAN . Internet is working fine


Some tricks here
-Not setting it up to use 802.1p priority based using port base with modified Priority setting below ( The settings reference is based on UserGuide of TP-SG108E , which has a weird matching, 802.1p Priority 0 is not mapped to the lowest setting of Port-base Queue settings
After getting direct connection from ONT to Switch to untagged internet connection to work.. Switching it back to 802.1p does not impact the settings any more.


Hardware Smart Switch :TP-link, TL-SG108E , version 3 Hardware,
FW:TL-SG108Ev3_en_1.0.0_[20160722-rel50167]_up

'->' Denotes LAN Connection
Network Flow

ONT->SWITCH->
Switch Ports
Port 1- ONT
Port 2- Tagged Port to serve as backup, to allow use of Singtel router/routers with Singtel Vlan settings
Port 3- To Routers without Vlan settings
Port 4-7 - Setup as Lan group ports , treat it as unmanaged switch , for use to route to other rooms AP/Switch/Bridge

Port-8 - Singtel IPTV

Overall View



Vlan Table


*Grouping of IPTV, can only select 2 ports, ONT and A single port, putting more than 2 ports slow down packet forwarding and resulted in stutter frames.


PVID Settings,
*actual setting, port 2 should have PVID 10





Prior to get 802.1P CoS to work, manual Port Base Priority was used.


Final 802.1p Settings



IGMP Snooping



Something to monitor with bad received packages



Next Step is to monitor Internet performance.
I am currently setup the network running at my home with Google On Hub x2 with MESH Setup.

Singtel 1G Fibre with MIO TV Package.

1.Singtel IPTV- Working
*The Vlan group for IPTV 20, can only have 2 ports ( 1,8 ONT +SIngle IPTV Output), grouping more than 2 will have pause video issue.

2. Internet - Working
-Video Streaming working fine
-Phone applications no abnormally



Internet Performance needs further validation

Internet connection with Wifi Mesh - 600 MBps up/download based on Google App transfer speed reporting

Internet Speed LAN-with Speedtest.net, misleading results

Speedtest.net ->
Download - 920 MBps ,
Upload ->500 Mbps with Singtel Server

-> Revert to ASUS AC 56S to ONT, got the same result range, Assuming server Busy or my LAN connection is having some problem. In the past , I would get 900/900 MBps range of LAN Connection.

SpeedTest.net Beta :> Downlaod speed < 200 MBps, Upload- 550 MBps with Singtel Server, other servers , no download speed.
sadboy, mrkiasu and commach like this.

Last edited by HMAN; 03-07-2018 at 09:40 PM.. Reason: v3 Edit- updated with IPTV Video settings
HMAN is offline   Reply With Quote
Old 26-12-2017, 02:56 PM   #2
Moderator
 
Join Date: Apr 2001
Posts: 53,907
Thanks for the hard work.

Any update or information on the 4655 received bad packets?
__________________
CSI in HWC, commach spotting idiots

Experience is the teacher of all things.
Julius Caesar
commach is offline   Reply With Quote
Old 27-12-2017, 02:55 PM   #3
Master Member
 
Join Date: Jan 2002
Posts: 3,271
I did some further probing and change of network settings but doesnt seem to improve the case.

There is always 10% bad package received at ONT point and no bad packets after Router.
My Fibre Point 2-3 weeks back got a disconnection issue that NetLinkTrust needs to do a physical patching, that could be the issue. The Noise level is still high.


Internet speed test didnt get impacted much, i still get 930/900 (Download/Upload) speed .

I didnt do port swapping to validate is the ONT port is broken.

Last edited by HMAN; 27-12-2017 at 02:58 PM..
HMAN is offline   Reply With Quote
Old 31-12-2017, 11:10 PM   #4
Master Member
 
Join Date: Jan 2002
Posts: 3,271
Full Setup Diagram

HMAN is offline   Reply With Quote
Old 25-01-2018, 10:59 PM   #5
Master Member
 
Join Date: Jan 2002
Posts: 3,271
Look like SingTel update its IPTV settings, turning on IGMp snooping will cause freezing frames, video keep pausing issue.

No choice, have to update settings to get IPTV to work.

Full Setup Diagram

HMAN is offline   Reply With Quote
Old 24-06-2018, 12:39 AM   #6
Master Member
 
Join Date: Nov 2001
Posts: 4,815
Any chance this thread can be updated?

All the pictures links are broken.
tidus792 is offline   Reply With Quote
Old 03-07-2018, 09:45 PM   #7
Master Member
 
Join Date: Jan 2002
Posts: 3,271
Any chance this thread can be updated?

All the pictures links are broken.
Updated drawing. Too long did not play with the settings..
HMAN is offline   Reply With Quote
Old 03-07-2018, 10:01 PM   #8
Member
 
Join Date: Mar 2016
Posts: 231
Lol im using this switch it works well just set port 8 highest priority 4 for iptv. Can even have multiple ports with detag vlan 10 for multi public ip..
HMAN likes this.
miloaisdino is offline   Reply With Quote
Old 03-07-2018, 10:28 PM   #9
Master Member
 
Join Date: Jan 2002
Posts: 3,271
Lol im using this switch it works well just set port 8 highest priority 4 for iptv. Can even have multiple ports with detag vlan 10 for multi public ip..
Perhaps you can share your setup to benefit the group here.

The Singtel IPTV settings kept changing , last time needed to turn on IGMP snooping but later have to disable it to get IPTV to work.
HMAN is offline   Reply With Quote
Old 03-07-2018, 10:46 PM   #10
Member
 
Join Date: Mar 2016
Posts: 231
Lol my config was in yr ither thread..https://imgur.com/a/xW1s26K
Port 1 - ONT trunk
Port 2 - Internet public ip 1
Port 3 - Internet public ip 2
Port 4 - Iptv
Port 5 - Passthrough for switch and ont management or stock singtel router (public ip 3 on vlan10)

Last edited by miloaisdino; 03-07-2018 at 10:49 PM..
miloaisdino is offline   Reply With Quote
Old 14-11-2018, 09:19 PM   #11
Junior Member
 
Join Date: Aug 2017
Posts: 3
Hi bro, still have the config screenshots? Link broken and when trying on my switch it just doesn't work zzz
toasterbot is offline   Reply With Quote
Old 14-11-2018, 09:59 PM   #12
Senior Member
 
Join Date: Sep 2018
Posts: 1,740
Hi bro, still have the config screenshots? Link broken and when trying on my switch it just doesn't work zzz
The one post above your post?
https://imgur.com/a/xW1s26K
xiaofan is online now   Reply With Quote
Old 14-11-2018, 11:10 PM   #13
Member
 
Join Date: Mar 2016
Posts: 231
The one post above your post?
https://imgur.com/a/xW1s26K
it works...
miloaisdino is offline   Reply With Quote
Old 16-12-2018, 04:50 PM   #14
Arch-Supremacy Member
 
Mclairs83's Avatar
 
Join Date: Jan 2000
Posts: 23,544
anybody able to get the setup works?

Modem --> SG105E HW v4 latest fw.

P1 - ONT
P2 - RT-N56U
P3 - Empty
P4 - Direct to Singtel MIOTV
P5 - Empty.

Did the above configuration according https://imgur.com/a/xW1s26K

But still not working on my MIOTV
Mclairs83 is offline   Reply With Quote
Old 16-12-2018, 09:14 PM   #15
Arch-Supremacy Member
 
renfred89's Avatar
 
Join Date: Nov 2007
Posts: 17,298
anybody able to get the setup works?

Modem --> SG105E HW v4 latest fw.

P1 - ONT
P2 - RT-N56U
P3 - Empty
P4 - Direct to Singtel MIOTV
P5 - Empty.

Did the above configuration according https://imgur.com/a/xW1s26K

But still not working on my MIOTV
port 4 for singtel tv must be tagged, not untagged.
__________________
-A Samsung Connections Member-
renfred89 is offline   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On