HWZ Forums

Login Register FAQ Mark Forums Read

Forum search function not working properly

Like Tree1Likes
Reply
 
LinkBack Thread Tools
Old 27-07-2019, 11:29 PM   #1
Arch-Supremacy Member
 
Pyre's Avatar
 
Join Date: Jan 2000
Posts: 20,270
Forum search function not working properly

1. subscribe to a thread. remember the thread title.
2. use the forum search function at the top of the forum webpage. search for the same thread title.
3. no result will appear.

then again i doubt anyone will actually fix this issue.
Pyre is online now   Reply With Quote
Old 31-07-2019, 01:47 PM   #2
Administrator
 
effervesce's Avatar
 
Join Date: May 2019
Posts: 139
Noted, will inform the tech
Pyre likes this.
effervesce is online now   Reply With Quote
Old 01-08-2019, 05:56 PM   #3
Administrator
 
effervesce's Avatar
 
Join Date: May 2019
Posts: 139
Hi Pyre,

It appears there is a limit to your search keyword count. Try reducing the amount of text and try again.
effervesce is online now   Reply With Quote
Old 01-08-2019, 06:05 PM   #4
Arch-Supremacy Member
 
Pyre's Avatar
 
Join Date: Jan 2000
Posts: 20,270
Hi Pyre,

It appears there is a limit to your search keyword count. Try reducing the amount of text and try again.
not sure which search they are using. i'm using this one.


to me, it doesn't work with ANY word that i try to search with. it USED to work until about a month or 2 ago. i just tried it, i searched using the word 'forum' and nothing appears to me. i used different browsers and even different PCs on different ISP/networks. same result which is NOTHING appears.
Pyre is online now   Reply With Quote
Old 05-08-2019, 05:45 PM   #5
Administrator
 
effervesce's Avatar
 
Join Date: May 2019
Posts: 139
Thanks for highlighting, the search next to HWZ presents works by pulling google cache. So it may take some time to reflect new posts.

You can try using the forum search besides new post button.
effervesce is online now   Reply With Quote
Old 09-08-2019, 08:43 AM   #6
Arch-Supremacy Member
 
Pyre's Avatar
 
Join Date: Jan 2000
Posts: 20,270


while you are at it, try even search the game 'just cause'.

says the words are too common, too long, too short.

but yet, it's a gaming series that has been around for ages and has many threads or posts on it. yet the search engine in this forum is unable to find it. but other forums can.

lol.

edit:


found it on page 18 of the gaming forum. the search engine of this forum needs a serious upgrade.
Pyre is online now   Reply With Quote
Old 13-08-2019, 09:11 PM   #7
Administrator
 
Dr.Vijay's Avatar
 
Join Date: Jan 2000
Posts: 25,009
Are there other examples of such text strings that you can't find?

We'll try to loosen up the limitations.

Chiefly there's a blacklist of common words that's in place to reduce the forum server search query loads and narrow down to only core subject matters.

However, this is a very old list, and it could use some updates.

Thanks!




while you are at it, try even search the game 'just cause'.

says the words are too common, too long, too short.

but yet, it's a gaming series that has been around for ages and has many threads or posts on it. yet the search engine in this forum is unable to find it. but other forums can.

lol.

edit:


found it on page 18 of the gaming forum. the search engine of this forum needs a serious upgrade.
__________________
Vijay Anand
Editor-in-Chief (www.HardwareZone.com) and Forum Administrator
Dr.Vijay is offline   Reply With Quote
Old 14-08-2019, 08:01 PM   #8
Arch-Supremacy Member
 
Pyre's Avatar
 
Join Date: Jan 2000
Posts: 20,270
Search for word "club"


Results


But it misses these threads
Pyre is online now   Reply With Quote
Old 14-08-2019, 09:35 PM   #9
Arch-Supremacy Member
 
Pyre's Avatar
 
Join Date: Jan 2000
Posts: 20,270
Search for the word "need"


Cannot find "Need for Speed"
Pyre is online now   Reply With Quote
Old 14-08-2019, 09:37 PM   #10
Arch-Supremacy Member
 
Pyre's Avatar
 
Join Date: Jan 2000
Posts: 20,270
Search for "star"


No "Star Citizen" thread appear in the search results
Pyre is online now   Reply With Quote
Old 15-08-2019, 12:40 AM   #11
High Supremacy Member
 
savoirex's Avatar
 
Join Date: Dec 2015
Posts: 25,383
I think the search function has been fixed. personally I think this search was broken for quite long time...
__________________
You ask me I ask who?
savoirex is online now   Reply With Quote
Old 15-08-2019, 08:50 AM   #12
Arch-Supremacy Member
 
Pyre's Avatar
 
Join Date: Jan 2000
Posts: 20,270
I think the search function has been fixed. personally I think this search was broken for quite long time...


here's another fine example.

Search for word "post" in this Feedback sub-forum.


Result from the search. 2 threads.


But on the front page of the Feedback sub-forum....
at least 2 other threads that were not found for some strange reason.


plox fix
Pyre is online now   Reply With Quote
Old 15-08-2019, 11:41 AM   #13
Arch-Supremacy Member
 
Pyre's Avatar
 
Join Date: Jan 2000
Posts: 20,270
1. Goto EDMW sub-forum.

2. Try searching for the "Open Electricity Market (OEM)" thread.

3. Let's compare results
Pyre is online now   Reply With Quote
Old Today, 07:10 AM   #14
Arch-Supremacy Member
 
Pyre's Avatar
 
Join Date: Jan 2000
Posts: 20,270
try searching "ghost recon". nothing.

but yet i had to manually locate my own thread.
Pyre is online now   Reply With Quote
Old Today, 02:45 PM   #15
Administrator
 
effervesce's Avatar
 
Join Date: May 2019
Posts: 139
Hi Pyre, thank you so much for the screenshots and examples.

Some of your search terms are stop words, meaning they're considered too common, so the server excluded it from indexing. We are currently reviewing the list of stop words so that the search can work better.
effervesce is online now   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On