HWZ Forums

Login Register FAQ Mark Forums Read

Microsoft Surface

Like Tree351Likes
Reply
 
LinkBack Thread Tools
Old 23-09-2014, 11:25 PM   #4696
Senior Member
 
Join Date: Jul 2001
Posts: 1,120
Has anyone installed the XtremeGuard Carbon Fiber back Protector?
How do you do the installation?
josephkjc is offline   Reply With Quote
Old 23-09-2014, 11:30 PM   #4697
Junior Member
 
Join Date: Nov 2006
Posts: 88
Ha... rain or shine or thunderstorm.... all no scared ...

Ever since I bought the MS complete, I have been able to walk around with my sp3 with more gusto and confidence.
mako140 is offline   Reply With Quote
Old 24-09-2014, 09:55 AM   #4698
Master Member
 
Join Date: Jul 2000
Posts: 2,577
Ha... rain or shine or thunderstorm.... all no scared ...
Actually I don't quite understand. It says in the T&Cs that deductible applies, but they did not state how much deductibles and under what conditions do they apply... Is it stated when you purchase the complete cover?
__________________
Join the dark side.
Bfrost is offline   Reply With Quote
Old 24-09-2014, 11:18 AM   #4699
Member
 
Join Date: Jun 2012
Posts: 394
Actually I don't quite understand. It says in the T&Cs that deductible applies, but they did not state how much deductibles and under what conditions do they apply... Is it stated when you purchase the complete cover?
Is that always capped at $100? Thats the excess like car insurance?
ticktick04 is offline   Reply With Quote
Old 24-09-2014, 12:41 PM   #4700
Banned
 
Join Date: Nov 2006
Posts: 1,097
any bro here knows how to set individual size scaling for dual monitor ?

It's kind of troublesome to go do setting everytime i plug in and out of the monitor.....
eijnaix is offline   Reply With Quote
Old 24-09-2014, 05:05 PM   #4701
Member
 
Join Date: Mar 2012
Posts: 405
Hi, anyone knows where I can get a arc touch mouse? Tried simlim and funan and it seems like it's out of stock everywhere!
flashbug is offline   Reply With Quote
Old 24-09-2014, 06:13 PM   #4702
Master Member
 
Join Date: Nov 2008
Posts: 3,952
Actually I don't quite understand. It says in the T&Cs that deductible applies, but they did not state how much deductibles and under what conditions do they apply... Is it stated when you purchase the complete cover?
It stated $50 deductible for a maximum of 2 exchanges. Not sure if it's in SGD or USD but it's cheap enough.
purpleberry is offline   Reply With Quote
Old 25-09-2014, 03:11 PM   #4703
Moderator
 
Vulpix's Avatar
 
Join Date: Jan 2000
Posts: 97,135
Read this pretty funny post of this guy getting sent 2x Surface Pro 3 instead of 1, then Microsoft charged him twice after he reported it, forcing him to have to find a solution to return it back or he won't be getting back that 2nd one $$$.
__________________
Path of Exile REVIVAL thread!
Vulpix is offline   Reply With Quote
Old 25-09-2014, 03:16 PM   #4704
High Supremacy Member
 
~大.芒.果~'s Avatar
 
Join Date: Nov 2007
Posts: 27,332
Has anyone installed the XtremeGuard Carbon Fiber back Protector?
How do you do the installation?
Use water!

What I did was...

1. Basin of water (put a bit of soap if you want) and a cloth ready. Switch off your SP3.
2. Put the skin/protective layer into the basin, ensure that the WHOLE THING is wet.
3. While its inside the water, peel out the protective layer. Make sure your hands are still wet while peeling it.
4. Let the excess water drip off back into the basin; there has to be some water left, but not too excessive. Don't dry your hands, especially for the transparent one, cause when you do, you can start seeing the fingerprints.
5. Place the skin on your SP3.
6. Squeeze out all the water to the sides during a credit card or something. Make sure your cloth is there to absorb the water coming out so it doesn't drip into your Surface. While the thing is still wet, you can adjust it in case its not aligned properly.
7. Once aligned perfectly, leave it there for a few hours for it to dry and stick
8. Done!

Do wrongly? No worry, just peel the whole thing out slowly and redo from Step #1.

Last edited by ~大.芒.果~; 25-09-2014 at 03:19 PM..
~大.芒.果~ is offline   Reply With Quote
Old 25-09-2014, 08:49 PM   #4705
Senior Member
 
Join Date: Oct 2009
Posts: 1,501
sorry guys
I dun see the complete coverage for 2 years in the Microsoft store
am I missing something?
Reborns is offline   Reply With Quote
Old 25-09-2014, 09:18 PM   #4706
Senior Member
 
Join Date: Nov 2004
Posts: 528
sorry guys
I dun see the complete coverage for 2 years in the Microsoft store
am I missing something?
Can only buy by calling their hotline
quailmaster is offline   Reply With Quote
Old 25-09-2014, 09:19 PM   #4707
Arch-Supremacy Member
 
Join Date: May 2005
Posts: 14,563
RE

Hi

Anyone tested the transfer speed of the SP3's USB 3.0 port?

I ran 2 tests transferring 131 GB of files each time from the external 2.5 inch SSD enclosures (SATA III to USB 3.0) using 2 different brands - STARTECH and HOTWAY PROBOX - both supporting UASP. Transfer is direct without going through a hub.

The result was disappointing for the transfer speed is about 245 MB/s. My SSD is the SAMSUNG 850 PRO 512 GB.

I thought with UASP the transfer speed using USB 3.0 should reach about 450 MB/s?

I think the 2 different SSD enclosures cannot be wrong. So is there something wrong with the SP3 USB 3.0 port's device driver?

Any advise? Thanks

Last edited by Apparatus; 25-09-2014 at 09:38 PM..
Apparatus is offline   Reply With Quote
Old 25-09-2014, 10:39 PM   #4708
Senior Member
 
Join Date: Jan 2008
Posts: 974
sorry guys
I dun see the complete coverage for 2 years in the Microsoft store
am I missing something?
Register your surface pro here at this link

register here

This will show you an extended warranty square box. If you need to purchase that you might need to give Microsoft a call to their hotline, it will be much more faster and painless.

BTW, it's only add 1 more year + 2 accidental damage. The existing warranty coverage without this plan is 1 year by default. so 1 + extended warranty 1 year is equal 2 years with +2 accident damage protection.

Hope this helps.
miragez is offline   Reply With Quote
Old 26-09-2014, 11:03 AM   #4709
Master Member
 
Join Date: Feb 2006
Posts: 3,210
(I started a thread to discuss this
)

When using earphones on the SP3, when I pause a video, after 30 seconds there will be popping sounds at a constant 2-3 times per second.

Anyone got this problem?

I found thread in another forum discussing this:
Audio Popping via Headphone Jack? | Microsoft Surface Forums

Tried installing realtek audio drivers but the problem is still there.
LoneReaction is offline   Reply With Quote
Old 26-09-2014, 11:37 AM   #4710
E_T
Master Member
 
E_T's Avatar
 
Join Date: Aug 2000
Posts: 3,095
any bro here knows how to set individual size scaling for dual monitor ?

It's kind of troublesome to go do setting everytime i plug in and out of the monitor.....
Try to install the proper driver for that monitor rather than the default PnP Monitor. Windows should remember the settings better when it's able to identify the model. Things like colour profile & resolution are remembered. Not sure about DPI what I think it's worth a shot since Win8 is suppose to have better multi-mon support.

Hi

Anyone tested the transfer speed of the SP3's USB 3.0 port?

I ran 2 tests transferring 131 GB of files each time from the external 2.5 inch SSD enclosures (SATA III to USB 3.0) using 2 different brands - STARTECH and HOTWAY PROBOX - both supporting UASP. Transfer is direct without going through a hub.

The result was disappointing for the transfer speed is about 245 MB/s. My SSD is the SAMSUNG 850 PRO 512 GB.

I thought with UASP the transfer speed using USB 3.0 should reach about 450 MB/s?

I think the 2 different SSD enclosures cannot be wrong. So is there something wrong with the SP3 USB 3.0 port's device driver?

Any advise? Thanks
First of all, what's the maximum sustained write speed of the SSD? Is it around 250MB/s? What about Read speed? The transfer speed will always follow the slowest link.

Have you tried it on a Desktop PC? Was the test done with the SP3 on battery power?
(I started a thread to discuss this
)

When using earphones on the SP3, when I pause a video, after 30 seconds there will be popping sounds at a constant 2-3 times per second.

Anyone got this problem?

I found thread in another forum discussing this:
Audio Popping via Headphone Jack? | Microsoft Surface Forums

Tried installing realtek audio drivers but the problem is still there.
Have you tried muting the mic?
LoneReaction likes this.
__________________
Read my blog at http://erictayet.wordpress.com or Follow me on Twitter @erictayet

Last edited by E_T; 26-09-2014 at 11:49 AM..
E_T is offline   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On