Unable to remote manage TP Link MR400 4G Router

spawnstar

Member
Joined
Jun 14, 2000
Messages
208
Reaction score
0
Had the above router connected on M1 network . However the router is "allocated" with a private IP address ( 10.143.x.x ) which i believe it the cause of my problem . The NAT is enable by default and internet will not work if I disable it. If i access the "What is My IP Address" , I can a public IP address .

The support team point the finger on M1 but using the same SIM on MR200 work perfectly. Working with them is a pain as the router is off-site and any troubleshooting is via email . Phone support is just L1 and they know nuts about it , just ask for detail for escalation .

Anyone face the same issue and manage to have a solution ?

any help of suggestion is greatly appreciated.
 

sadboy

Master Member
Joined
Nov 24, 2000
Messages
2,538
Reaction score
12
You are referring to add the 4G router into TPLINk cloud app for remote manage?
 

uncle_josh

Senior Member
Joined
Jun 16, 2018
Messages
1,676
Reaction score
19
Due to the lack of IPv4 address, SG telco quietly routing all IPv4 connections through carrier grade NAT(CGNAT) and the ISP does not provide IPV6. Hence you are facing this issue and getting 10.143.x.x

Google for "How bypass ISP using CGNAT" maybe you can find solution to your issue.
 
Last edited:

spawnstar

Member
Joined
Jun 14, 2000
Messages
208
Reaction score
0
You are referring to add the 4G router into TPLINk cloud app for remote manage?
Am I suppose to add the router into the cloud app. I had the MR200 and because the NAT option is not there , it can automatically get a public up and I can remote manage it by typing the ip on my browser
 

uncle_josh

Senior Member
Joined
Jun 16, 2018
Messages
1,676
Reaction score
19
Dey, adding the router into TPLink cloud app and getting a public/private ip address are totally 2 different thing.

Private-IP-Address.jpg

Due to CGNat, your ISP is managing the Class A NAT
Your TPLink router can only manage the Class C NAT.

The Network Address Translation (NAT) is transparent to the user. It is automatically turn on when router is running in router mode and turned off on bridge mode.
 

bert64

Member
Joined
Jan 20, 2020
Messages
499
Reaction score
54
Due to the lack of IPv4 address, SG telco quietly routing all IPv4 connections through carrier grade NAT(CGNAT) and the ISP does not provide IPV6. Hence you are facing this issue and getting 10.143.x.x

Google for "How bypass ISP using CGNAT" maybe you can find solution to your issue.
M1 does have support for IPv6, and the addresses are fully routable. If you have IPv6 enabled on the router and on whatever connection you're trying to remote manage from you should have no trouble connecting via the IPv6 address the router gets.
 

sadboy

Master Member
Joined
Nov 24, 2000
Messages
2,538
Reaction score
12
Am I suppose to add the router into the cloud app. I had the MR200 and because the NAT option is not there , it can automatically get a public up and I can remote manage it by typing the ip on my browser

It really been awhile I seen 4G mobile issue Public IP address.

U can try added MR200 to TPlink App and see if you can manage via the app.
 

spawnstar

Member
Joined
Jun 14, 2000
Messages
208
Reaction score
0
It really been awhile I seen 4G mobile issue Public IP address.

U can try added MR200 to TPlink App and see if you can manage via the app.
I can remote manage the MR200 directly without any issue , tried on 2 diff M1 SIM card . Same 2 card on MR400 failed . TPLink support still insists is M1 issue for giving it a private Ip. Both sim card work well on Dlink 4G router too .

I can access the admin page when I am connected via WiFi . But the router is offsite where I hardly go there. Cannot manage is not a big issue but just a pain if I need to check which device is using excessive data .
 

bert64

Member
Joined
Jan 20, 2020
Messages
499
Reaction score
54
I can remote manage the MR200 directly without any issue , tried on 2 diff M1 SIM card . Same 2 card on MR400 failed . TPLink support still insists is M1 issue for giving it a private Ip. Both sim card work well on Dlink 4G router too .

I can access the admin page when I am connected via WiFi . But the router is offsite where I hardly go there. Cannot manage is not a big issue but just a pain if I need to check which device is using excessive data .
What address is the MR200 getting?
 

sadboy

Master Member
Joined
Nov 24, 2000
Messages
2,538
Reaction score
12
I can remote manage the MR200 directly without any issue , tried on 2 diff M1 SIM card . Same 2 card on MR400 failed . TPLink support still insists is M1 issue for giving it a private Ip. Both sim card work well on Dlink 4G router too .

I can access the admin page when I am connected via WiFi . But the router is offsite where I hardly go there. Cannot manage is not a big issue but just a pain if I need to check which device is using excessive data .

Can't explain why dlink give you public IP where TP-link give a private IP. Since M1 only has 1 APN Sunsurf.

I check on my M1 sim on phone it also issue a private IP

egDgnnX.jpg


uoZkXAi.jpg



pretty much nothing TPlink can do since the Ip is issue by M1.
 

bert64

Member
Joined
Jan 20, 2020
Messages
499
Reaction score
54
Can't explain why dlink give you public IP where TP-link give a private IP. Since M1 only has 1 APN Sunsurf.

I check on my M1 sim on phone it also issue a private IP

egDgnnX.jpg


uoZkXAi.jpg



pretty much nothing TPlink can do since the Ip is issue by M1.

For me, M1 assigns a private IPv4 and a public IPv6. If you have IPv6 turned off as in the screenshot above, you'd only get the private IPv4.

I'm able to connect to my handset from the outside using IPv6, if i tether my laptop i can even reach that from the outside too.

A link from a guy who talks about it in a bit more detail:
https://thirdinternet.com/ipv6-on-mobile-devices/
 

sadboy

Master Member
Joined
Nov 24, 2000
Messages
2,538
Reaction score
12
For me, M1 assigns a private IPv4 and a public IPv6. If you have IPv6 turned off as in the screenshot above, you'd only get the private IPv4.

I'm able to connect to my handset from the outside using IPv6, if i tether my laptop i can even reach that from the outside too.

A link from a guy who talks about it in a bit more detail:
https://thirdinternet.com/ipv6-on-mobile-devices/

That means my lousy phone no support IPV6 as i didnt even turn it out before. Out of the box plug in sim card
 

bert64

Member
Joined
Jan 20, 2020
Messages
499
Reaction score
54
That means my lousy phone no support IPV6 as i didnt even turn it out before. Out of the box plug in sim card
Depends on the phone... some android phones have outdated carrier profiles with ipv6 disabled by default. Try turning it on in the apn settings and see if that works?
 
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.
Top