HWZ Forums

Login Register FAQ Mark Forums Read

Advise on Cable - Fast Charge

Like Tree3Likes
  • 1 Post By NightRaven49
  • 1 Post By Teo Ming Ern
  • 1 Post By NightRaven49
Reply
 
LinkBack Thread Tools
Old 15-10-2019, 04:43 PM   #1
Member
 
Join Date: Jan 2019
Posts: 265
Advise on Cable - Fast Charge

I have a new cable and I have 2 Redmi phones.

One of the phone will show the fast charge indicator when I use other cables with the same charger. But the new cable, the indicator does not show up.

For the 2nd phone, the phone itself does not show the fast charge indicator at all with any cables (I think due to some bug in the OS) but when I use the new cable, the current exceeds 1A. Can be 1400-1500, I've seen.

So the 2nd phone shows that the cable is able to deliver > 1A. I take it that it's able to do fast charging. However, the indicator does not show up on the 1st phone. So I'm confused. Help please.

Thanks very very much.
GoodBetterBest is offline   Reply With Quote
Old 16-10-2019, 09:10 AM   #2
Member
 
NightRaven49's Avatar
 
Join Date: May 2019
Posts: 241
could be possible the cable is not rated for the quick charge current. u could install ampere on both phones and check the actual current the phones draw using different cables. also which redmi phones are u using? older phones may not support any quick charge standards.
GoodBetterBest likes this.
NightRaven49 is offline   Reply With Quote
Old 16-10-2019, 09:44 AM   #3
Supremacy Member
 
Join Date: Jan 2000
Posts: 9,538
I have a new cable and I have 2 Redmi phones.

One of the phone will show the fast charge indicator when I use other cables with the same charger. But the new cable, the indicator does not show up.

For the 2nd phone, the phone itself does not show the fast charge indicator at all with any cables (I think due to some bug in the OS) but when I use the new cable, the current exceeds 1A. Can be 1400-1500, I've seen.

So the 2nd phone shows that the cable is able to deliver > 1A. I take it that it's able to do fast charging. However, the indicator does not show up on the 1st phone. So I'm confused. Help please.

Thanks very very much.
What cable are you using? And which phones?

Try buying better cables from Anker or Remax or even the original Xiaomi cable... they're worth the premium.
GoodBetterBest likes this.
Teo Ming Ern is offline   Reply With Quote
Old 16-10-2019, 12:48 PM   #4
Member
 
NightRaven49's Avatar
 
Join Date: May 2019
Posts: 241
don't see the point spending so much in peripherals. my current usbc cable I bought for $4 in taiwan over a year ago, rated only for 2.4a but my phone regularly pulls more than 3a, no problems so far. my previous phone also same thing.
GoodBetterBest likes this.
NightRaven49 is offline   Reply With Quote
Reply
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.


Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On