Help desktop died

multijesture

Senior Member
Joined
Dec 20, 2011
Messages
814
Reaction score
0
While using halfway, suddenly no video output, usb all die, my rgb mouse and keyboard stop working, no light

I have removed my wifi pci adaptor, my mouse and keyboard, tested only with hdmi output

Then i restart my computer. Sometimes the video output straight away die, sometimes it can make it to the login screen then die.

If my usb peripherals are plugged in, they also die at the same time the video output dies.

What should i do now:cry:
 

jtjt00

Arch-Supremacy Member
Joined
Jan 1, 2000
Messages
16,089
Reaction score
1
TS, list down all parts of your rig here.
 

multijesture

Senior Member
Joined
Dec 20, 2011
Messages
814
Reaction score
0
Asus b350 f mobo
Ryzen 5 cpu
Samsung ssd
Galax gtx 1060 6gb
Evga 550w gold psu
Corsair 8gb ram x 2
 

jtjt00

Arch-Supremacy Member
Joined
Jan 1, 2000
Messages
16,089
Reaction score
1
You can try the following:
1. GPU
2. PSU
 

destiny88

Senior Member
Joined
Jun 9, 2006
Messages
1,515
Reaction score
3
could be CPU, temps too high overheat, try changing the CPU cooler 1st. if that does not solves the issues try GPU.
 

yusoffb01

Arch-Supremacy Member
Joined
Jun 17, 2008
Messages
13,224
Reaction score
23
easy to troubleshoot.
ram test. if ok buy new psu,
if cannot, rma motherboard
 

magix

Arch-Supremacy Member
Joined
May 28, 2000
Messages
16,663
Reaction score
12
Can try to

1. Reseat the gtx 1060 and Memory. (if fail)
2. Power up the system with Corsair DIMM 1. (if rail)
3. removed Corsair DIMM 1 and install Corsair DIMM 2 and see if system can power up.
 

multijesture

Senior Member
Joined
Dec 20, 2011
Messages
814
Reaction score
0
Sorry i forgot to add on, when the problem occurs, my rgb fans and gpu still have light and are running. So maybe its not the psu problem?

I dont really have spare parts to swap n test
 

jtjt00

Arch-Supremacy Member
Joined
Jan 1, 2000
Messages
16,089
Reaction score
1
Sorry i forgot to add on, when the problem occurs, my rgb fans and gpu still have light and are running. So maybe its not the psu problem?

I dont really have spare parts to swap n test
Bring to Nigel at PC Care and Solution, #02-32 Sim Lim Square since you don't have spare to test. Fans and LED light are on doesn't mean that PSU is fine.
 
Important Forum Advisory Note
This forum is moderated by volunteer moderators who will react only to members' feedback on posts. Moderators are not employees or representatives of HWZ. Forum members and moderators are responsible for their own posts.

Please refer to our Terms of Service for more information.
Top